FooGallery Premium <= 2.3.3 - Authenticated (Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-6747
CVSS 6.4 (Medium)
Publicly Published January 2, 2024
Last Updated January 30, 2024
Researchers Webbernaut
Debangshu Kundu
Arpeet Rathi
István Márton - Wordfence


The Best WordPress Gallery Plugin – FooGallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom attributes in all versions up to, and including, 2.3.3 due to insufficient input sanitization and output escaping. This makes it possible for contributors and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



2 affected software packages

Software Type Plugin
Software Slug foogallery (view on
Patched? Yes
Remediation Update to version 2.4.9, or a newer patched version
Affected Version
  • <= 2.4.8
Patched Version
  • 2.4.9
Software Type Plugin
Software Slug foogallery-premium
Patched? Yes
Remediation Update to version 2.4.6, or a newer patched version
Affected Version
  • <= 2.3.3
Patched Version
  • 2.4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.