Sensei LMS <= 4.23.1 & Sensei Pro (WC Paid Courses) <= - Missing Authorization

Missing Authorization
CVE CVE-2024-35686
CVSS 5.3 (Medium)
Publicly Published June 6, 2024
Last Updated June 13, 2024
Researcher Rafie Muhammad - Patchstack


The Sensei LMS and Sensei Pro (WC Paid Courses) plugins for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the flush_rewrite_rules() function in versions up to, and including, 4.23.1 and . respectively. This makes it possible for unauthenticated attackers to flush rewrite rules.



2 affected software packages

Software Type Plugin
Software Slug sensei-lms (view on
Patched? Yes
Remediation Update to version 4.24.0, or a newer patched version
Affected Version
  • <= 4.23.1
Patched Version
  • 4.24.0
Software Type Plugin
Software Slug woothemes-sensei
Patched? Yes
Remediation Update to version, or a newer patched version
Affected Version
  • <=
Patched Version

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.