Widget Options - Extended <= 5.1.0 & Widget Options <= 4.0.1 - Authenticated (Subscriber+) Information Disclosure

Information Exposure
CVE CVE-2024-35691
CVSS 4.3 (Medium)
Publicly Published June 6, 2024
Last Updated June 13, 2024
Researcher Dave Jong - Patchstack


The Widget Options - Extended plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to 5.1.3 (exclusive) for Widget Options - Extended and all versions up to, and including, 4.0.1 for Widget Options. This makes it possible for unauthenticated attackers to extract sensitive data including private/draft posts and user meta. CVE-2024-35690 was also assigned to this issue (specifically for the free version)



2 affected software packages

Software Type Plugin
Software Slug extended-widget-options
Patched? Yes
Remediation Update to version 5.1.3, or a newer patched version
Affected Version
  • < 5.1.3
Patched Version
  • 5.1.3
Software Type Plugin
Software Slug widget-options (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.2, or a newer patched version
Affected Version
  • <= 4.0.1
Patched Version
  • 4.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.