WordPress Core < 4.1.2 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2015-3438
CVSS 7.2 (High)
Publicly Published April 21, 2015
Last Updated August 14, 2023
Researcher Jakub Zoczek


Multiple cross-site scripting (XSS) vulnerabilities in WordPress before 4.1.2, when MySQL is used without strict mode, allow remote attackers to inject arbitrary web script or HTML via a (1) four-byte UTF-8 character or (2) invalid character that reaches the database layer, as demonstrated by a crafted character in a comment.



1 affected software package

Software Type Core
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 3.7.6, 3.8.6, 3.9.4, 4.0.2, 4.1.2
Affected Versions
  • < 3.7
  • 3.7 - 3.7.5
  • 3.8 - 3.8.5
  • 3.9 - 3.9.3
Expand to see 2 more affected version ranges.
  • 4.0 - 4.0.1
  • 4.1 - 4.1.1
Patched Versions
  • 3.7.6
  • 3.8.6
  • 3.9.4
  • 4.0.2
Expand to see 1 more patched version.
  • 4.1.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.