WordPress Core <= 4.5.3 - Denial of Service

Uncontrolled Resource Consumption ('Resource Exhaustion')
CVE CVE-2016-6896
CVSS 6.5 (Medium)
Publicly Published August 22, 2016
Last Updated December 5, 2022
Researcher Yorick Koster, - sumofpwn


Directory traversal vulnerability in the wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress 4.5.3 allows remote authenticated users to cause a denial of service or read certain text files via a .. (dot dot) in the plugin parameter to wp-admin/admin-ajax.php, as demonstrated by /dev/random read operations that deplete the entropy pool.



1 affected software package

Software Type Core
Patched? Yes
Remediation Update to version 4.6, or a newer patched version
Affected Version
  • < 4.6
Patched Version
  • 4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.