WordPress Core 5.9-6.3.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via Navigation Attributes

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-38000
CVSS 6.4 (Medium)
Publicly Published October 12, 2023
Last Updated February 12, 2024
Researchers Rafie Muhammad - Patchstack
Edourard L - Patchstack


WordPress Core is vulnerable to Stored Cross-Site Scripting via the arrow navigation block attributes in versions between 5.9 and 6.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with contributor-level privileges and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



2 affected software packages

Software Type Plugin
Software Slug gutenberg (view on wordpress.org)
Patched? Yes
Remediation Update to version 16.8.1, or a newer patched version
Affected Version
  • <= 16.8.0
Patched Version
  • 16.8.1
Software Type Core
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2
Affected Versions
  • 5.9 - 5.9.7
  • 6.0 - 6.0.5
  • 6.1 - 6.1.3
  • 6.2 - 6.2.2
Expand to see 1 more affected version range.
  • 6.3 - 6.3.1
Patched Versions
  • 5.9.8
  • 6.0.6
  • 6.1.4
  • 6.2.3
Expand to see 1 more patched version.
  • 6.3.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.