WordPress Core < 6.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via use of the_meta(); function

4.9
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 4.9 (Medium)
Publicly Published August 30, 2022
Last Updated December 5, 2022
Researcher John Blackbourn

Description

WordPress Core, in versions up to 6.0.2, is vulnerable to Authenticated Stored Cross-Site Scripting that can be exploited by users with access to the WordPress post and page editor, typically consisting of Authors, Contributors, and Editors making it possible to inject arbitrary web scripts into posts and pages that execute if the the_meta(); function is called on that page.

Wordfence blocked 24 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Core
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 3.7.39, 3.8.39, 3.9.37, 4.0.36, 4.1.36, 4.2.33, 4.3.29, 4.4.28, 4.5.27, 4.6.24, 4.7.24, 4.8.20, 4.9.21, 5.0.17, 5.1.14, 5.2.16, 5.3.13, 5.4.11, 5.5.10, 5.6.9, 5.7.7, 5.8.5, 5.9.4, 6.0.2
Affected Versions
  • <= 3.6.1
  • 5.5 - 5.5.9
  • 5.6 - 5.6.8
  • 5.7 - 5.7.6
Expand to see 21 more affected version ranges.
  • 5.8 - 5.8.4
  • 5.9 - 5.9.3
  • 6.0 - 6.0.1
  • 3.7 - 3.7.38
  • 3.8 - 3.8.38
  • 3.9 - 3.9.36
  • 4.0 - 4.0.35
  • 4.1 - 4.1.35
  • 4.2 - 4.2.32
  • 4.3 - 4.3.28
  • 4.4 - 4.4.27
  • 4.5 - 4.5.26
  • 4.6 - 4.6.23
  • 4.7 - 4.7.23
  • 4.8 - 4.8.19
  • 4.9 - 4.9.20
  • 5.0 - 5.0.16
  • 5.1 - 5.1.13
  • 5.2 - 5.2.15
  • 5.3 - 5.3.12
  • 5.4 - 5.4.10
Patched Versions
  • 3.7.39
  • 3.8.39
  • 3.9.37
  • 4.0.36
Expand to see 20 more patched versions.
  • 4.1.36
  • 4.2.33
  • 4.3.29
  • 4.4.28
  • 4.5.27
  • 4.6.24
  • 4.7.24
  • 4.8.20
  • 4.9.21
  • 5.0.17
  • 5.1.14
  • 5.2.16
  • 5.3.13
  • 5.4.11
  • 5.5.10
  • 5.6.9
  • 5.7.7
  • 5.8.5
  • 5.9.4
  • 6.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation