WordPress Core <= 6.4.3 - Sensitive Information Exposure via redirect_guess_404_permalink

Information Exposure
CVE CVE-2023-5692
CVSS 5.3 (Medium)
Publicly Published April 4, 2024
Last Updated April 5, 2024
Researcher Francesco Carlucci


WordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including, 6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.



1 affected software package

Software Type Core
Patched? Yes
Remediation Update to version 6.5, or a newer patched version
Affected Version
  • <= 6.4.3
Patched Version
  • 6.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.