WordPress Core < 6.5.2 - Unauthenticated & Authenticated (Contributor+) Stored Cross-Site Scripting via Avatar Block

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-4439
CVSS 7.2 (High)
Publicly Published April 9, 2024
Last Updated May 3, 2024
Researchers John Blackbourn


WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. In addition, it also makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that have the comment block present and display the comment author's avatar.



1 affected software package

Software Type Core
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2
Affected Versions
  • 6.0 - 6.0.7
  • 6.1 - 6.1.5
  • 6.2 - 6.2.4
  • 6.3 - 6.3.3
Expand to see 2 more affected version ranges.
  • 6.4 - 6.4.3
  • 6.5 - 6.5.1
Patched Versions
  • 6.0.8
  • 6.1.6
  • 6.2.5
  • 6.3.4
Expand to see 2 more patched versions.
  • 6.4.4
  • 6.5.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.