DearFlip <= 2.2.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via force_fit

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-29807
CVSS 6.4 (Medium)
Publicly Published March 25, 2024
Last Updated March 28, 2024
Researcher emad


The DearFlip plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'force_fit ' parameter in versions up to, and including, 2.2.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for PDF Flipbook, 3D Flipbook, PDF embed, PDF viewer – DearFlip

Software Type Plugin
Software Slug 3d-flipbook-dflip-lite (view on
Patched? Yes
Remediation Update to version 2.2.27, or a newer patched version
Affected Version
  • <= 2.2.26
Patched Version
  • 2.2.27

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.