PDF Flipbook, 3D Flipbook – DearFlip <= 2.2.26 - Authenticated (Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-0895
CVSS 5.4 (Medium)
Publicly Published February 2, 2024
Last Updated February 3, 2024
Researcher Muhammad Daffa


The PDF Flipbook, 3D Flipbook – DearFlip plugin for WordPress is vulnerable to Stored Cross-Site Scripting via outline settings in all versions up to, and including, 2.2.26 due to insufficient input sanitization and output escaping on user supplied data. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for PDF Flipbook, 3D Flipbook, PDF embed, PDF viewer – DearFlip

Software Type Plugin
Software Slug 3d-flipbook-dflip-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.27, or a newer patched version
Affected Version
  • <= 2.2.26
Patched Version
  • 2.2.27

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.