AffiliateWP <= 2.14.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Plugin Activation

Missing Authorization
CVE CVE-2023-4600
CVSS 4.3 (Medium)
Publicly Published August 29, 2023
Last Updated August 30, 2023
Researcher Lana Codes - Wordfence


The AffiliateWP for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'affwp_activate_addons_page_plugin' function called via an AJAX action in versions up to, and including, 2.14.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to activate arbitrary plugins.



1 affected software package

Software Type Plugin
Software Slug AffiliateWP
Patched? Yes
Remediation Update to version 2.14.1, or a newer patched version
Affected Version
  • 2.14.0 - 2.14.0
Patched Version
  • 2.14.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.