ActiveDEMAND <= 0.2.27 - Missing Authorization Checks

Missing Authorization
CVE CVE-2022-36296
CVSS 9.8 (Critical)
Publicly Published August 2, 2022
Last Updated January 22, 2024
Researcher Tien Nguyen Ahn - Patchstack Alliance


The ActiveDEMAND plugin for WordPress is vulnerable to unauthenticated post updates and deletion due to missing authorization checks in the api_save_post and api_delete_post functions called via REST APIs in versions up to, and including 0.2.27. This makes it possible for unauthenticated attackers to modify posts.



Vulnerability Details for ActiveDEMAND

Software Type Plugin
Software Slug activedemand (view on
Patched? Yes
Remediation Update to version 0.2.28, or a newer patched version
Affected Version
  • <= 0.2.27
Patched Version
  • 0.2.28

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.