Ad Inserter <= 2.7.30 - Unauthenticated Sensitive Information Exposure via ai-debug-processing-fe

Missing Authorization
CVE CVE-2023-4668
CVSS 5.3 (Medium)
Publicly Published September 22, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The Ad Inserter for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 2.7.30 via the ai-debug-processing-fe URL parameter. This can allow unauthenticated attackers to extract sensitive data including installed plugins (present and active), active theme, various plugin settings, WordPress version, as well as some server settings such as memory limit, installation paths.



1 affected software package

Software Type Plugin
Software Slug ad-inserter (view on
Patched? Yes
Remediation Update to version 2.7.31, or a newer patched version
Affected Version
  • <= 2.7.30
Patched Version
  • 2.7.31

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.