Ivory Search <= 5.4 - Multiple Admin+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-25105
CVSS 4.8 (Medium)
Publicly Published January 10, 2022
Last Updated January 8, 2023
Researcher Yoru Oni


The Ivory Search WordPress plugin before 5.4.1 does not escape some of the Form settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.



Vulnerability Details for Ivory Search – WordPress Search Plugin

Software Type Plugin
Software Slug add-search-to-menu (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.4.1, or a newer patched version
Affected Version
  • <= 5.4
Patched Version
  • 5.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.