Elementor Addon Elements <= 1.11.1 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24259
CVSS 5.4 (Medium)
Publicly Published April 13, 2021
Last Updated January 18, 2023
Researcher Ram - Wordfence


The “Elementor Addon Elements” WordPress Plugin before 1.11.2 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.



Vulnerability Details for Elementor Addon Elements

Software Type Plugin
Software Slug addon-elements-for-elementor-page-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.11.2, or a newer patched version
Affected Version
  • < 1.11.2
Patched Version
  • 1.11.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.