Elementor Addon Elements <= 1.12.12 - Directory Traversal to Local File Inclusion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-1358
CVSS 8.8 (High)
Publicly Published February 21, 2024
Last Updated March 13, 2024
Researcher wesley (wcraft)


The Elementor Addon Elements plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.12.12 via the render function. This makes it possible for authenticated attackers, with contributor access or higher, to include the contents of arbitrary PHP files on the server, which may expose sensitive information.



Vulnerability Details for Elementor Addon Elements

Software Type Plugin
Software Slug addon-elements-for-elementor-page-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.13, or a newer patched version
Affected Version
  • <= 1.12.12
Patched Version
  • 1.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.