Elementor Addon Elements <= 1.12.7 - Missing Authorization to Sensitive Information Exposure

Missing Authorization
CVE CVE-2023-4723
CVSS 5.3 (Medium)
Publicly Published November 15, 2023
Last Updated January 22, 2024
Researchers Marco Wotschka - Wordfence
Paolo Tresso - Wordfence


The Elementor Addon Elements plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.12.7 via the ajax_eae_post_data function. This can allow unauthenticated attackers to extract sensitive data including post/page ids and titles including those of with pending/draft/future/private status.



1 affected software package

Software Type Plugin
Software Slug addon-elements-for-elementor-page-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.12.8, or a newer patched version
Affected Version
  • <= 1.12.7
Patched Version
  • 1.12.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.