WPBakery Page Builder Addons by Livemesh <= 3.8.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-2079
CVSS 6.4 (Medium)
Publicly Published March 13, 2024
Last Updated March 13, 2024
Researcher Krzysztof Zając - CERT PL


The WPBakery Page Builder Addons by Livemesh plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'per_line_mobile' shortcode in all versions up to, and including, 3.8.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for WPBakery Page Builder Addons by Livemesh

Software Type Plugin
Software Slug addons-for-visual-composer (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.8.3, or a newer patched version
Affected Version
  • <= 3.8.1
Patched Version
  • 3.8.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.