Admin and Site Enhancements (ASE) <= 5.7.1 - Password Protection Mode Security Feature Bypass

Improper Authentication
CVE CVE-2023-46630
CVSS 7.5 (High)
Publicly Published October 25, 2023
Last Updated October 27, 2023
Researcher Abu Hurayra (HurayraIIT) - WPDeveloper


The Admin and Site Enhancements (ASE) plugin for WordPress is vulnerable to security feature bypass in all versions up to, and including, 5.7.1. This is due to a flawed authentication mechanism within the maybe_process_login function. This makes it possible for unauthenticated attackers to bypass the Password Protection feature and view password protected pages.



1 affected software package

Software Type Plugin
Software Slug admin-site-enhancements (view on
Patched? Yes
Remediation Update to version 5.8.0, or a newer patched version
Affected Version
  • <= 5.7.1
Patched Version
  • 5.8.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.