Ads by <= 1.1.3 - Unauthenticated (Limited) Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2023-5843
CVSS 9.0 (Critical)
Publicly Published October 30, 2023
Last Updated November 8, 2023
Researcher István Márton - Wordfence


The Ads by plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 1.1.3 via the 'dfads_ajax_load_ads' function. This allows unauthenticated attackers to execute code on the server. The parameters of the callable function are limited, they cannot be specified arbitrarily.



1 affected software package

Software Type Plugin
Software Slug ads-by-datafeedrcom (view on
Patched? Yes
Remediation Update to version 1.2.0, or a newer patched version
Affected Version
  • <= 1.1.3
Patched Version
  • 1.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.