Advanced Menu Manager <= 3.0.6 - Authenticated (Subscriber+) Menu Creation/Deletion

Missing Authorization
CVSS 5.4 (Medium)
Publicly Published July 12, 2021
Last Updated November 13, 2023
Researcher WPScanTeam - WPScan


The Advanced Menu Manager plugin for WordPress is vulnerable to Arbitrary Menu Creation/Deletion in versions up to, and including, 3.0.6. This is due to missing capability and nonce checks in its 'my_action_delete_menu' and 'my_action_create_menu_ajax' AJAX actions. This makes it possible for authenticated attackers (unauthenticated if performed via CSRF) to create and/or delete arbitrary menus.



Vulnerability Details for Advance Menu Manager

Software Type Plugin
Software Slug advance-menu-manager (view on
Patched? Yes
Remediation Update to version 3.0.7, or a newer patched version
Affected Version
  • <= 3.0.6
Patched Version
  • 3.0.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.