Advanced Access Manager <= 5.9.8.1 - Unauthenticated Arbitrary File Read

9.8
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVSS 9.8 (Critical)
Publicly Published September 9, 2019
Last Updated January 16, 2023
Researcher Ov3rfly

Description

The Advanced Access Manager plugin for WordPress is vulnerable to Unauthenticated Arbitrary File Read in versions up to, and including, 5.9.8.1 due to insufficient validation on the aam-media parameter. This allows unauthenticated attackers to read any file on the server, including sensitive files such as wp-config.php

Wordfence blocked 21,100 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug advanced-access-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.9.9, or a newer patched version
Affected Version
  • < 5.9.9
Patched Version
  • 5.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation