Advanced Custom Fields <= 5.8.11 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2020-36172
CVSS 6.1 (Medium)
Publicly Published June 10, 2020
Last Updated January 18, 2023


The Advanced Custom Fields plugin before 5.8.12 for WordPress mishandles the escaping of strings in Select2 dropdowns, potentially leading to XSS.



1 affected software package

Software Type Plugin
Software Slug advanced-custom-fields (view on
Patched? Yes
Remediation Update to version 5.8.12, or a newer patched version
Affected Version
  • < 5.8.12
Patched Version
  • 5.8.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.