Advanced Custom Fields <= 6.0.2 - Authenticated (Contributor+) Information Disclosure

Information Exposure
CVE CVE-2022-40696
CVSS 4.3 (Medium)
Publicly Published October 18, 2022
Last Updated January 18, 2023
Researcher Juan Hoffmann


The Advanced Custom Fields plugin for WordPress is vulnerable to Sensitive Data Exposure in versions up to, and including, 6.0.2. While the ACF shortcode ensures that the ACF data being accessed is valid data that has been entered into ACF fields, it may be possible with certain site configurations, that contributor-level users may extract sensitive user or configuration data.



Vulnerability Details for Advanced Custom Fields (ACF)

Software Type Plugin
Software Slug advanced-custom-fields (view on
Patched? Yes
Remediation Update to version 6.0.3, or a newer patched version
Affected Version
  • <= 6.0.2
Patched Version
  • 6.0.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.