Advanced Custom Fields <= 6.0.7 - Authenticated (Contributor+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2023-1196
CVSS 8.8 (High)
Publicly Published April 3, 2023
Last Updated April 12, 2023
Researcher Nguyen Huu Do


The Advanced Custom Fields plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 6.0.7 via deserialization of untrusted input in custom field values. This makes it possible for authenticated attackers, with contributor-level permissions, and above to inject a PHP Object. No POP chain appears to be present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



1 affected software package

Software Type Plugin
Software Slug advanced-custom-fields (view on
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 5.12.5, 6.1.0
Affected Versions
  • <= 5.12.4
  • 6.0.0 - 6.0.7
Patched Versions
  • 5.12.5
  • 6.1.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.