Advanced Dynamic Pricing for WooCommerce <= 4.1.5 - Missing Authorization in ajaxCalculateSeveralProducts function

Missing Authorization
CVE CVE-2022-40203
CVSS 4.3 (Medium)
Publicly Published February 17, 2023
Last Updated February 22, 2023
Researcher Lana Codes


The Advanced Dynamic Pricing for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the ajaxCalculateSeveralProducts function in versions up to, and including, 4.1.5. This makes it possible for authenticated attackers with subscriber-level access or higher to obtain advance pricing info.



1 affected software package

Software Type Plugin
Software Slug advanced-dynamic-pricing-for-woocommerce (view on
Patched? Yes
Remediation Update to version 4.1.6, or a newer patched version
Affected Version
  • <= 4.1.5
Patched Version
  • 4.1.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.