Advanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms <= 1.82.0 - SQL Injection to Reflected Cross-Site Scripting via integration_id

6.1
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2024-2387
CVSS 6.1 (Medium)
Publicly Published March 19, 2024
Last Updated March 20, 2024
Researcher Krzysztof Zając - CERT PL

Description

The Advanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms plugin for WordPress is vulnerable to SQL Injection via the ‘integration_id’ parameter in all versions up to, and including, 1.82.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries and subsequently inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Advanced Form Integration – Connect WooCommerce and Contact Form 7 to Google Sheets and other platforms

Software Type Plugin
Software Slug advanced-form-integration (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.82.6, or a newer patched version
Affected Version
  • <= 1.82.0
Patched Version
  • 1.82.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation