Advanced Local Pickup for WooCommerce <= 1.5.2 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published March 31, 2023
Last Updated January 22, 2024


The Advanced Local Pickup for WooCommerce for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.5.2. This is due to missing or incorrect nonce validation on the functions wclp_update_state_dropdown_fun, wclp_update_work_hours_list_fun, wclp_update_edit_location_form_fun, and wclp_apply_work_hours_fun. This makes it possible for unauthenticated attackers to invoke those functions resulting in plugin settings changes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Advanced Local Pickup for WooCommerce

Software Type Plugin
Software Slug advanced-local-pickup-for-woocommerce (view on
Patched? Yes
Remediation Update to version 1.5.3, or a newer patched version
Affected Version
  • <= 1.5.2
Patched Version
  • 1.5.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.