Advanced Post Block – Display Posts, Pages, or Custom Posts on Your Page <= 1.13.4 - Missing Authorization to Information Disclosure

Missing Authorization
CVE CVE-2024-0908
CVSS 5.3 (Medium)
Publicly Published April 11, 2024
Last Updated May 9, 2024
Researcher Krzysztof Zając - CERT PL


The Advanced Post Block – Display Posts, Pages, or Custom Posts on Your Page plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the apbPosts() function hooked via an AJAX action in all versions up to, and including, 1.13.4. This makes it possible for unauthenticated attackers to retrieve all post data, including those that may be password protected.



Vulnerability Details for Advanced Post Block- Great solution for displaying Posts

Software Type Plugin
Software Slug advanced-post-block (view on
Patched? Yes
Remediation Update to version 1.13.5, or a newer patched version
Affected Version
  • <= 1.13.4
Patched Version
  • 1.13.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.