AffiEasy <= 1.1.6 - Cross-Site Request Forgery to Various Actions

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-4218
CVSS 6.5 (Medium)
Publicly Published May 29, 2024
Last Updated June 6, 2024
Researcher Benedictus Jovan (aillesiM)


The AffiEasy plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.6. This is due to plugin improperly releasing the tagged and patched version of the plugin - the vulnerable version is used as the core files, while the patched version was included in a 'trunk' folder. This makes it possible for unauthenticated attackers to perform a variety of actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for AffiEasy

Software Type Plugin
Software Slug affieasy (view on
Patched? Yes
Remediation Update to version 1.1.7, or a newer patched version
Affected Version
  • <= 1.1.6
Patched Version
  • 1.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.