Affiliates Manager <= 2.9.34 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2024-0859
CVSS 4.3 (Medium)
Publicly Published January 30, 2024
Last Updated February 5, 2024
Researcher Nathaniel Oh (0x4n3)

Description

The Affiliates Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.9.34. This is due to missing or incorrect nonce validation on the process_bulk_action function in ListAffiliatesTable.php. This makes it possible for unauthenticated attackers to delete affiliates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Affiliates Manager

Software Type Plugin
Software Slug affiliates-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.9.35, or a newer patched version
Affected Version
  • <= 2.9.34
Patched Version
  • 2.9.35

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation