Absolutely Glamorous Custom Admin <= 6.8 - Authenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-36823
CVSS 6.6 (Medium)
Publicly Published September 23, 2021
Last Updated January 22, 2024
Researcher Jorgson


Authenticated Stored Cross-Site Scripting (XSS) vulnerability in WordPress Absolutely Glamorous Custom Admin plugin (versions <= 6.8). Stored XSS possible via unsanitized input fields of the plugin settings, some of the payloads could make the frontend and the backend inaccessible.



Vulnerability Details for AGCA – Custom Dashboard & Login Page

Software Type Plugin
Software Slug ag-custom-admin (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.9, or a newer patched version
Affected Version
  • <= 6.8
Patched Version
  • 6.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.