10Web AI Assistant – AI content writing assistant <= 1.0.18 - Missing Authorization to Arbitrary Plugin Installation

Missing Authorization
CVE CVE-2023-6985
CVSS 6.5 (Medium)
Publicly Published January 25, 2024
Last Updated February 5, 2024
Researcher Krzysztof Zając - CERT PL


The 10Web AI Assistant – AI content writing assistant plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the install_plugin AJAX action in all versions up to, and including, 1.0.18. This makes it possible for authenticated attackers, with subscriber-level access and above, to install arbitrary plugins that can be used to gain further access to a compromised site.



Vulnerability Details for 10Web AI Assistant – AI content writing assistant

Software Type Plugin
Software Slug ai-assistant-by-10web (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.19, or a newer patched version
Affected Version
  • <= 1.0.18
Patched Version
  • 1.0.19

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.