AI Post Generator | AutoWriter <= 3.3 - Missing Authorization

Missing Authorization
CVE CVE-2024-1850
CVSS 6.3 (Medium)
Publicly Published March 21, 2024
Last Updated April 29, 2024
Researcher Lucio Sá


The AI Post Generator | AutoWriter plugin for WordPress is vulnerable to unauthorized access, modification or deletion of posts due to a missing capability check on functions hooked by AJAX actions in all versions up to, and including, 3.3. This makes it possible for authenticated attackers, with subscriber access or higher, to view all posts generated with this plugin (even in non-published status), create new posts (and publish them), publish unpublished post or perform post deletions. CVE-2024-32713 may be a duplicate of this issue.



Vulnerability Details for AI Post Generator | AutoWriter

Software Type Plugin
Software Slug ai-post-generator (view on
Patched? Yes
Remediation Update to version 3.4, or a newer patched version
Affected Version
  • <= 3.3
Patched Version
  • 3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.