All in One SEO – Best WordPress SEO Plugin – Easily Improve SEO Rankings & Increase Traffic <= 2.3.6 - Stored Cross-Site Scripting

7.2
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 7.2 (High)
Publicly Published July 1, 2016
Last Updated January 22, 2024
Researcher David Vaartjes

Description

The All in One SEO – Best WordPress SEO Plugin – Easily Improve SEO Rankings & Increase Traffic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the HTTP_REFERER header in versions up to, and including, 2.3.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Wordfence blocked 1 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for All in One SEO – Powerful SEO Plugin to Boost SEO Rankings & Increase Traffic

Software Type Plugin
Software Slug all-in-one-seo-pack (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.3.7, or a newer patched version
Affected Version
  • < 2.3.7
Patched Version
  • 2.3.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation