All in One SEO Pack <= 2.3.7 - Unauthenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 7.2 (High)
Publicly Published July 13, 2016
Last Updated January 22, 2024
Researcher Panagiotis Vagenas - Wordfence


The All in One SEO Pack plugin for WordPress is vulnerable to unauthenticated stored Cross-Site Scripting via unspecified vectors that make it possible for attackers to inject arbitrary web scripts into web pages that will execute when a victim accesses the page in versions up to, and including, 2.3.7. Please note that this exploit only works if the user has enabled the sitemap module in the plugin.



Vulnerability Details for All in One SEO – Powerful SEO Plugin to Boost SEO Rankings & Increase Traffic

Software Type Plugin
Software Slug all-in-one-seo-pack (view on
Patched? Yes
Remediation Update to version 2.3.8, or a newer patched version
Affected Version
  • < 2.3.8
Patched Version
  • 2.3.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.