All-in-One Video Gallery 2.5.8 - 2.6.0 - Arbitrary File Download & Server-Side Request Forgery

7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2022-2633
CVSS 7.5 (High)
Publicly Published August 17, 2022
Last Updated January 11, 2024
Researcher Gabriele Zuddas

Description

The All-in-One Video Gallery plugin for WordPress is vulnerable to arbitrary file downloads and blind server-side request forgery via the 'dl' parameter found in the ~/public/video.php file in versions up to, and including 2.6.0. This makes it possible for unauthenticated users to download sensitive files hosted on the affected server and forge requests to the server.

Wordfence blocked 1 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for All-in-One Video Gallery

Software Type Plugin
Software Slug all-in-one-video-gallery (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.1, or a newer patched version
Affected Version
  • 2.5.8 - 2.6.0
Patched Version
  • 2.6.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation