All-In-One Security (AIOS) <= 5.1.4 - Authenticated(Admin+) Directory Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-0156
CVSS 4.9 (Medium)
Publicly Published February 14, 2023
Last Updated March 29, 2023
Researcher Bartłomiej Marek


The All-In-One Security (AIOS) plugin for WordPress is vulnerable to directory traversal in versions up to, and including, 5.1.4. This allows authenticated attackers with administrator-level permissions to read the contents of arbitrary files on the server.



1 affected software package

Software Type Plugin
Software Slug all-in-one-wp-security-and-firewall (view on
Patched? Yes
Remediation Update to version 5.1.5, or a newer patched version
Affected Version
  • <= 5.1.4
Patched Version
  • 5.1.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.