Anti Hacker <= 4.19 - Missing Authorization to Arbitrary Plugin Install

Improper Access Control
CVE CVE-2022-3880
CVSS 6.5 (Medium)
Publicly Published November 21, 2022
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The Anti Hacker plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the antihacker_install_plugin() function in versions up to, and including, 4.19. This makes it possible for authenticated attackers with minimal permission, such as a subscriber, to install arbitrary plugins on the vulnerable site. This could be used to install additional vulnerable plugins that could aid in further compromise of the site.



Vulnerability Details for Disable Json API, Login Lockdown, XMLRPC, Pingback, Stop User Enumeration Anti Hacker Scan

Software Type Plugin
Software Slug antihacker (view on
Patched? Yes
Remediation Update to version 4.20, or a newer patched version
Affected Version
  • <= 4.19
Patched Version
  • 4.20

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.