Appointment Hour Booking <= 1.3.55 - Authenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1710
CVSS 4.8 (Medium)
Publicly Published May 23, 2022
Last Updated January 22, 2024
Researcher Bruno Halltari


The Appointment Hour Booking WordPress plugin before 1.3.56 does not sanitise and escape a settings of its Calendar fields, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed.



Vulnerability Details for Appointment Hour Booking – WordPress Booking Plugin

Software Type Plugin
Software Slug appointment-hour-booking (view on
Patched? Yes
Remediation Update to version 1.3.56, or a newer patched version
Affected Version
  • <= 1.3.55
Patched Version
  • 1.3.56

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.