AppPresser <= 4.2.5 - Insecure Password Reset Mechanism

Unverified Password Change
CVE CVE-2023-4214
CVSS 8.1 (High)
Publicly Published November 16, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence


The AppPresser plugin for WordPress is vulnerable to unauthorized password resets in versions up to, and including 4.2.5. This is due to the plugin generating too weak a reset code, and the code used to reset the password has no attempt or time limit.



1 affected software package

Software Type Plugin
Software Slug apppresser (view on
Patched? Yes
Remediation Update to version 4.3.0, or a newer patched version
Affected Version
  • <= 4.2.5
Patched Version
  • 4.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.