ARForms <= 1.5.8 - Unauthenticated Stored Cross-Site Scripting via arf_http_referrer_url

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-6828
CVSS 7.2 (High)
Publicly Published January 3, 2024
Last Updated January 11, 2024
Researcher drop


The Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘ arf_http_referrer_url’ parameter in all versions up to, and including, 1.5.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder

Software Type Plugin
Software Slug arforms-form-builder (view on
Patched? Yes
Remediation Update to version 1.5.9, or a newer patched version
Affected Version
  • <= 1.5.8
Patched Version
  • 1.5.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.