ARMember <= 4.0.24 - Improper Access Control to Sensitive Information Exposure via REST API

Improper Access Control
CVE CVE-2024-0969
CVSS 5.3 (Medium)
Publicly Published February 1, 2024
Last Updated February 5, 2024
Researcher Francesco Carlucci


The ARMember plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.21 via the REST API. This makes it possible for unauthenticated attackers to bypass the plugin's "Default Restriction" feature and view restricted post content.



Vulnerability Details for ARMember – Membership Plugin, Content Restriction, Member Levels, User Profile & User signup

Software Type Plugin
Software Slug armember-membership (view on
Patched? Yes
Remediation Update to version 4.0.25, or a newer patched version
Affected Version
  • <= 4.0.24
Patched Version
  • 4.0.25

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.