Starter Templates — Elementor, WordPress & Beaver Builder Templates <= 4.1.6 - Authenticated (Contributor+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2024-1467
CVSS 4.3 (Medium)
Publicly Published May 8, 2024
Last Updated May 9, 2024
Researcher Lucio Sá


The Starter Templates — Elementor, WordPress & Beaver Builder Templates plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.1.6 via the ai_api_request(). This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Starter Templates — Elementor, WordPress & Beaver Builder Templates

Software Type Plugin
Software Slug astra-sites (view on
Patched? Yes
Remediation Update to version 4.1.7, or a newer patched version
Affected Version
  • <= 4.1.6
Patched Version
  • 4.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.