authLdap <= 2.5.8 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-41654
CVSS 4.3 (Medium)
Publicly Published September 1, 2023
Last Updated September 7, 2023
Researcher Rio Darmawan

Description

The authLdap plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.8. This is due to missing or incorrect nonce validation on the authLdap_options_panel() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug authldap (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.5.9, or a newer patched version
Affected Version
  • <= 2.5.8
Patched Version
  • 2.5.9

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation