Autoptimize <= 2.8.3 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24332
CVSS 5.5 (Medium)
Publicly Published May 7, 2021
Last Updated January 19, 2023
Researcher Vladislav Pokrovsky


The Autoptimize WordPress plugin before 2.8.4 was missing proper escaping and sanitisation in some of its settings, allowing high privilege users to set XSS payloads in them, leading to stored Cross-Site Scripting issues.



1 affected software package

Software Type Plugin
Software Slug autoptimize (view on
Patched? Yes
Remediation Update to version 2.8.4, or a newer patched version
Affected Version
  • < 2.8.4
Patched Version
  • 2.8.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.