Autoptimize <= 3.0.4 - Sensitive Information Disclosure

Information Exposure
CVE CVE-2022-4057
CVSS 5.3 (Medium)
Publicly Published December 5, 2022
Last Updated January 19, 2023
Researcher Raad Haddad


The Autoptimize plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 3.0.4 via the 'ao_ccss_export_callback' and 'ao_ccss_import_callback' functions. The settings.json file is not deleted in the import/export callbacks, which could lead to the settings options being leaked. This can allow unauthenticated attackers to extract sensitive data about the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug autoptimize (view on
Patched? Yes
Remediation Update to version 3.1.0, or a newer patched version
Affected Version
  • <= 3.0.4
Patched Version
  • 3.1.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.