Awesome Support <= 6.1.6 - Insufficient Authorization via wpas_can_delete_attachments()

Incorrect Authorization
CVE CVE-2024-24716
CVSS 4.3 (Medium)
Publicly Published March 12, 2024
Last Updated March 12, 2024
Researcher Brandon James Roldan (tomorrowisnew)


The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to an insufficient capability check in the wpas_can_delete_attachments() function in all versions up to, and including 6.1.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete attachments.



1 affected software package

Software Type Plugin
Software Slug awesome-support (view on
Patched? Yes
Remediation Update to version 6.1.7, or a newer patched version
Affected Version
  • <= 6.1.6
Patched Version
  • 6.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.