Awesome Support – WordPress HelpDesk & Support Plugin <= 6.1.7 - Missing Authorization via editor_html()

5.3
Missing Authorization
CVE CVE-2024-0596
CVSS 5.3 (Medium)
Publicly Published February 9, 2024
Last Updated February 10, 2024
Researcher Krzysztof Zając - CERT PL

Description

The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the editor_html() function in all versions up to, and including, 6.1.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to view password protected and draft posts.

References

Share

Vulnerability Details for Awesome Support – WordPress HelpDesk & Support Plugin

Software Type Plugin
Software Slug awesome-support (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.1.8, or a newer patched version
Affected Version
  • <= 6.1.7
Patched Version
  • 6.1.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation